Vulnerability CVE-2006-3196


Published: 2006-06-22   Modified: 2012-02-12

Description:
index.php in singapore 0.10.0 and earlier allows remote attackers to obtain the installation path via an invalid template parameter, which reveals the path in an error message.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
singapore gallery <= 0.10.0 Multiple Vulnerabilities
simo64 gmail com
28.06.2006

Type:

CWE-Other

Vendor: Singapore
Product: Singapore 
Version:
0.9_beta
0.9a_beta
0.9.9b_beta
0.9.9a_beta
0.9.8_beta
0.9.7_beta
0.9.7
0.9.6_beta
0.9.5_beta
0.9.4_beta
0.9.3_beta
0.9.2_beta
0.9.1_beta
0.9.11_beta
0.9.10_beta
0.9.10
0.10.0

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None

 References:
http://securityreason.com/securityalert/1135
http://www.securityfocus.com/archive/1/437716/100/0/threaded
https://exchange.xforce.ibmcloud.com/vulnerabilities/27323

Related CVE
CVE-2008-0400
Cross-site scripting (XSS) vulnerability in header.tpl.php in the modern template for Singapore 0.10.1 allows remote attackers to inject arbitrary web script or HTML via the gallery parameter to default.php.
CVE-2007-3229
index.php in Singapore Gallery allows remote attackers to obtain sensitive information via a request with a non-directory gallery parameter, which reveals the path in an error message.
CVE-2006-3194
Directory traversal vulnerability in index.php in singapore 0.10.0 and earlier allows remote attackers to read arbitrary files via a .. (dot dot) sequence and trailing null (%00) byte in the (1) gallery and (2) template parameter.
CVE-2006-3195
Cross-site scripting (XSS) vulnerability in index.php in singapore 0.10.0 and earlier allows remote attackers to inject arbitrary web script or HTML via the template parameter.
CVE-2006-2262
Cross-site scripting (XSS) vulnerability in index.php in singapore 0.9.7 allows remote attackers to inject arbitrary web script or HTML via the image parameter.
CVE-2005-1954
singapore 0.9.11 allows remote attackers to obtain sensitive information via a direct request to (1) admin.class.php, (2) any .tpl.php file in templates/admin_default/, or (3) any .tpl.php file in templates/default/, which reveal the path in an error...
CVE-2005-1955
Cross-site scripting (XSS) vulnerability in index.php in singapore 0.9.11 allows remote attackers to inject arbitrary web script or HTML via the gallery parameter.
CVE-2004-1407
Multiple directory traversal vulnerabilities in singapore Image Gallery Web Application 0.9.10 allow remote attackers to (1) read arbitrary files via the showThumb method for thumb.php, or (2) delete arbitrary files via admin.class.php.

Copyright 2019, cxsecurity.com

 

Back to Top