Vulnerability CVE-2006-3694


Published: 2006-07-21   Modified: 2012-02-12

Description:
Multiple unspecified vulnerabilities in Ruby before 1.8.5 allow remote attackers to bypass "safe level" checks via unspecified vectors involving (1) the alias function and (2) "directory operations".

Type:

CWE-DesignError

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.4/10
4.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
None
Affected software
Yukihiro matsumoto -> RUBY 

 References:
http://www.ubuntu.com/usn/usn-325-1
http://www.securityfocus.com/bid/18944
http://www.redhat.com/support/errata/RHSA-2006-0604.html
http://www.debian.org/security/2006/dsa-1139
http://secunia.com/advisories/21337
http://secunia.com/advisories/21272
http://secunia.com/advisories/21236
http://secunia.com/advisories/21233
http://secunia.com/advisories/21009
http://xforce.iss.net/xforce/xfdb/27725
http://www.vupen.com/english/advisories/2006/2760
http://www.osvdb.org/27145
http://www.osvdb.org/27144
http://www.novell.com/linux/security/advisories/2006_21_sr.html
http://www.mandriva.com/security/advisories?name=MDKSA-2006:134
http://www.debian.org/security/2006/dsa-1157
http://secunia.com/advisories/21749
http://secunia.com/advisories/21657
http://secunia.com/advisories/21598
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9983
http://lists.freebsd.org/pipermail/freebsd-security/2006-July/003915.html
http://lists.freebsd.org/pipermail/freebsd-security/2006-July/003907.html
http://jvn.jp/jp/JVN%2383768862/index.html
http://jvn.jp/jp/JVN%2313947696/index.html
ftp://patches.sgi.com/support/free/security/advisories/20060801-01-P

Copyright 2022, cxsecurity.com

 

Back to Top