Vulnerability CVE-2006-7098


Published: 2007-03-03   Modified: 2012-02-12

Description:
The Debian GNU/Linux 033_-F_NO_SETSID patch for the Apache HTTP Server 1.3.34-4 does not properly disassociate httpd from a controlling tty when httpd is started interactively, which allows local users to gain privileges to that tty via a CGI program that calls the TIOCSTI ioctl.

Type:

CWE-264

(Permissions, Privileges, and Access Controls)

CVSS2 => (AV:L/AC:M/Au:S/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.6/10
10/10
2.7/10
Exploit range
Attack complexity
Authentication
Local
Medium
Single time
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Debian -> Apache 

 References:
http://xforce.iss.net/xforce/xfdb/32708
http://www.securityfocus.com/bid/22732
http://secunia.com/advisories/24324
http://osvdb.org/33816
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=357561
http://archives.neohapsis.com/archives/fulldisclosure/2007-02/0579.html

Copyright 2021, cxsecurity.com

 

Back to Top