Vulnerability CVE-2007-0245


Published: 2007-06-12   Modified: 2012-02-12

Description:
Heap-based buffer overflow in OpenOffice.org (OOo) 2.2.1 and earlier allows remote attackers to execute arbitrary code via a RTF file with a crafted prtdata tag with a length parameter inconsistency, which causes vtable entries to be overwritten.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:M/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9.3/10
10/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Openoffice -> Openoffice 

 References:
ftp://patches.sgi.com/support/free/security/advisories/20070602-01-P.asc
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102917-1
http://sw.openoffice.org/source/browse/sw/sw/source/filter/rtf/swparrtf.cxx?rev=1.67
http://www.debian.org/security/2007/dsa-1307
http://www.gentoo.org/security/en/glsa/glsa-200707-02.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2007:144
http://www.novell.com/linux/security/advisories/2007_37_openoffice.html
http://www.redhat.com/support/errata/RHSA-2007-0406.html
http://www.securityfocus.com/archive/1/471274/100/0/threaded
http://www.securityfocus.com/bid/24450
http://www.securitytracker.com/id?1018239
http://www.ubuntu.com/usn/usn-482-1
http://www.vupen.com/english/advisories/2007/2166
http://www.vupen.com/english/advisories/2007/2229
https://exchange.xforce.ibmcloud.com/vulnerabilities/34843
https://issues.rpath.com/browse/RPL-1570
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10002

Copyright 2022, cxsecurity.com

 

Back to Top