Vulnerability CVE-2007-1673


Published: 2007-05-08   Modified: 2012-02-12

Description:
unzoo.c, as used in multiple products including AMaViS 2.4.1 and earlier, allows remote attackers to cause a denial of service (infinite loop) via a ZOO archive with a direntry structure that points to a previous file.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
Multiple vendors ZOO file decompression infinite loop DoS
Jean-Sebastien G...
12.05.2007

Type:

CWE-399

(Resource Management Errors)

Vendor: Barracuda networks
Product: Barracuda spam firewall 
Version:
model_900
model_800
model_600
model_500
model_400
model_300
model_200
model_100
Vendor: Avira
Product: Antivir personal 
Version: 7.3.0.5; 7;
Product: Antivir 
Version: 7.04.00.23; 6.35.00.00;
Vendor: Avast
Product: Avast antivirus 
Version:
4.7.980
4.7.700
4.7.652
4.6.394
Product: Avast antivirus professional 
Version:
4.7.869
4.7.844
4.7.827
4.7.1098
4.7.1043
4.6.691
4.6.665
4.6.652
4.6.603
4.6
4.0
Product: Avast antivirus home 
Version:
4.7.869
4.7.844
4.7.827
4.7.1098
4.7.1043
4.6.691
4.6.665
4.6.655
4.6.652
4.6
4.0
Vendor: Unzoo
Product: Unzoo 
Version: 4.4;
Vendor: Panda
Product: Panda antivirus 
Version: 2007;
Product: Panda antivirus and firewall 
Version: 2007;
Vendor: Amavis
Product: Amavis 
Version: 2.4.1;
Vendor: Rahul dhesi
Product: ZOO 
Version: 2.10;
Vendor: Winace
Product: Winace 
Vendor: Picozip
Product: Picozip 

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.8/10
6.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Complete

 References:
http://securityreason.com/securityalert/2680
http://www.amavis.org/security/asa-2007-2.txt
http://www.securityfocus.com/archive/1/467646/100/0/threaded
http://www.securityfocus.com/bid/23823
https://exchange.xforce.ibmcloud.com/vulnerabilities/34080

Related CVE
CVE-2007-2536
PicoZip allows remote attackers to cause a denial of service (infinite loop) via a ZOO archive with a direntry structure that points to a previous file.
CVE-2007-2058
Directory traversal vulnerability in Acubix PicoZip 4.02 allows user-assisted remote attackers to overwrite arbitrary files via a .. (dot dot) sequence in the file path in an (1) GZ, (2) TAR, (3) RAR, (4) JAR, or (5) ZIP archive.
CVE-2006-2909
Stack-based buffer overflow in the info tip shell extension (zipinfo.dll) in PicoZip 4.01 allows remote attackers to execute arbitrary code via a long filename in an (1) ACE, (2) RAR, or (3) ZIP archive, which is triggered when the user moves the mou...

Copyright 2019, cxsecurity.com

 

Back to Top