Vulnerability CVE-2007-2239


Published: 2007-05-07   Modified: 2012-02-12

Description:
Stack-based buffer overflow in the SaveBMP method in the AXIS Camera Control (aka CamImage) ActiveX control before 2.40.0.0 in AxisCamControl.ocx in AXIS 2100, 2110, 2120, 2130 PTZ, 2420, 2420-IR, 2400, 2400+, 2401, 2401+, 2411, and Panorama PTZ allows remote attackers to cause a denial of service (Internet Explorer crash) or execute arbitrary code via a long argument.

Vendor: AXIS
Product: 2401 video server 
Version: 2.39;
Product: 2100 network camera 
Version: 2.39;
Product: 2420-ir network camera 
Version: 2.39;
Product: 2120 network camera 
Version: 2.39;
Product: Panorama ptz camera 
Version: 2.39;
Product: 2400 video server 
Version: 2.39;
Product: 2411 video server 
Version: 2.39;
Product: 2110 network camera 
Version: 2.39;
Product: 2420 network camera 
Version: 2.39;
Product: 2130 ptz network camera 
Version: 2.39;

CVSS2 => (AV:N/AC:M/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9.3/10
10/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete

 References:
http://www.kb.cert.org/vuls/id/355809
http://secunia.com/advisories/25093
http://www.vupen.com/english/advisories/2007/1663
http://www.axis.com/techsup/software/acc/files/acc_security_update_1_00.pdf
http://osvdb.org/35602
http://xforce.iss.net/xforce/xfdb/34133
http://www.securityfocus.com/bid/23816

Related CVE
CVE-2018-10664
An issue was discovered in the httpd process in multiple models of Axis IP Cameras. There is Memory Corruption.
CVE-2018-10663
An issue was discovered in multiple models of Axis IP Cameras. There is an Incorrect Size Calculation.
CVE-2018-10662
An issue was discovered in multiple models of Axis IP Cameras. There is an Exposed Insecure Interface.
CVE-2018-10661
An issue was discovered in multiple models of Axis IP Cameras. There is a bypass of access control.
CVE-2018-10660
An issue was discovered in multiple models of Axis IP Cameras. There is Shell Command Injection.
CVE-2018-10659
There was a Memory Corruption issue discovered in multiple models of Axis IP Cameras which allows remote attackers to cause a denial of service (crash) by sending a crafted command which will result in a code path that calls the UND undefined ARM ins...
CVE-2018-10658
There was a Memory Corruption issue discovered in multiple models of Axis IP Cameras which causes a denial of service (crash). The crash arises from code inside libdbus-send.so shared object or similar.
CVE-2018-9158
An issue was discovered on AXIS M1033-W (IP camera) Firmware version 5.40.5.1 devices. They don't employ a suitable mechanism to prevent a DoS attack, which leads to a response time delay. An attacker can use the hping3 tool to perform an IPv4 flood ...

Copyright 2019, cxsecurity.com

 

Back to Top