Vulnerability CVE-2007-3769


Published: 2007-07-15   Modified: 2012-02-12

Description:
Cross-site scripting (XSS) vulnerability in the mirrored server management interface in SurgeFTP 2.3a1 allows user-assisted, remote FTP servers to inject arbitrary web script or HTML via a malformed response without a status code, which is reflected to the user in the resulting error message. NOTE: this can be leveraged for root access via a sequence of steps involving web script that creates a new FTP user account.

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5.8/10
4.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
Partial
Affected software
Netwin -> Surgeftp 

 References:
http://marc.info/?l=full-disclosure&m=118409539009277&w=2
http://xforce.iss.net/xforce/xfdb/35378
http://www.vupen.com/english/advisories/2007/2528
http://secunia.com/advisories/26061
http://osvdb.org/37911
http://lists.grok.org.uk/pipermail/full-disclosure/attachments/20070710/98374694/attachment-0031.txt

Copyright 2022, cxsecurity.com

 

Back to Top