Vulnerability CVE-2007-5249


Published: 2007-10-06   Modified: 2012-02-12

Description:
Multiple buffer overflows in the logging function in the Unreal engine, as used by America's Army and America's Army Special Forces 2.8.2 and earlier, when Punkbuster (PB) is enabled, allow remote attackers to cause a denial of service (daemon crash) via a long (1) PB_Y packet to the YPG server on UDP port 1716 or (2) PB_U packet to UCON on UDP port 1716, different vectors than CVE-2007-4442. NOTE: this issue might be in Punkbuster itself, but there are insufficient details to be certain.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
Unexploitable buffer-overflow in America\'s Army 2.8.2 through PB
Luigi Auriemma
06.10.2007

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

Vendor: Americasarmy
Product: America's army 
Version: 2.8.2;
Product: America's army special forces 
Version: 2.8.2;

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial

 References:
http://aluigi.altervista.org/adv/aaboompb-adv.txt
http://aluigi.org/poc/aaboompb.zip
http://securityreason.com/securityalert/3193
http://www.securityfocus.com/archive/1/481227/100/0/threaded
https://exchange.xforce.ibmcloud.com/vulnerabilities/36897

Copyright 2019, cxsecurity.com

 

Back to Top