Vulnerability CVE-2007-5360


Published: 2008-01-08   Modified: 2012-02-12

Description:
Buffer overflow in OpenPegasus Management server, when compiled to use PAM and with PEGASUS_USE_PAM_STANDALONE_PROC defined, as used in VMWare ESX Server 3.0.1 and 3.0.2, might allow remote attackers to execute arbitrary code via vectors related to PAM authentication, a different vulnerability than CVE-2008-0003.

See advisories in our WLB2 database:
Topic
Author
Date
High
Moderate OpenPegasus PAM Authentication Buffer Overflow and updated service console packages
Alexander Sotiro...
13.01.2008

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Vmware -> Esx server 
Vmware -> ESX 
Openpegasus -> Management server 

 References:
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01438409
http://lists.vmware.com/pipermail/security-announce/2008/000002.html
http://securityreason.com/securityalert/3538
http://www.attrition.org/pipermail/vim/2008-January/001879.html
http://www.novell.com/linux/security/advisories/suse_security_summary_report.html
http://www.securityfocus.com/archive/1/485936/100/0/threaded
http://www.securityfocus.com/archive/1/486859/100/0/threaded
http://www.vmware.com/security/advisories/VMSA-2008-0001.html
http://www.vupen.com/english/advisories/2008/0063
http://www.vupen.com/english/advisories/2008/0064
http://www.vupen.com/english/advisories/2008/1391/references
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2007-5360
https://exchange.xforce.ibmcloud.com/vulnerabilities/39524

Copyright 2020, cxsecurity.com

 

Back to Top