Vulnerability CVE-2007-5395


Published: 2007-11-07   Modified: 2012-02-12

Description:
Stack-based buffer overflow in the separate_word function in tokenize.c in Link Grammar 4.1b and possibly other versions, as used in AbiWord Link Grammar 4.2.4, allows remote attackers to execute arbitrary code via a long word, as reachable through the separate_sentence function.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
10/10
10/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Link grammar -> Link grammar 
Abiword -> Abiword link grammar 

 References:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=450695
http://bugs.gentoo.org/show_bug.cgi?id=196803
http://security.gentoo.org/glsa/glsa-200711-27.xml
http://www.debian.org/security/2007/dsa-1432
http://www.securityfocus.com/archive/1/483368/100/0/threaded
http://www.securityfocus.com/archive/1/483370/100/0/threaded
http://www.securityfocus.com/bid/26365
http://www.ubuntu.com/usn/usn-545-1
http://www.vupen.com/english/advisories/2007/3770
http://www.vupen.com/english/advisories/2007/3771
https://bugzilla.redhat.com/show_bug.cgi?id=371221
https://exchange.xforce.ibmcloud.com/vulnerabilities/38317
https://www.redhat.com/archives/fedora-package-announce/2007-November/msg00411.html

Copyright 2020, cxsecurity.com

 

Back to Top