Vulnerability CVE-2007-6013


Published: 2007-11-19   Modified: 2012-02-12

Description:
Wordpress 1.5 through 2.3.1 uses cookie values based on the MD5 hash of a password MD5 hash, which allows attackers to bypass authentication by obtaining the MD5 hash from the user database, then generating the authentication cookie from that hash.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
Wordpress Cookie Authentication Vulnerability
Steven J. Murdoc...
20.11.2007

Type:

CWE-287

(Improper Authentication)

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Wordpress -> Wordpress 

 References:
http://lists.grok.org.uk/pipermail/full-disclosure/2007-November/058576.html
http://securityreason.com/securityalert/3375
http://trac.wordpress.org/ticket/5367
http://www.cl.cam.ac.uk/~sjm217/advisories/wordpress-cookie-auth.txt
http://www.securityfocus.com/archive/1/483927/100/0/threaded
http://www.securitytracker.com/id?1018980
http://www.vupen.com/english/advisories/2007/3941
https://exchange.xforce.ibmcloud.com/vulnerabilities/38578
https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00079.html
https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00098.html

Copyright 2021, cxsecurity.com

 

Back to Top