Vulnerability CVE-2007-6318


Published: 2007-12-11   Modified: 2012-02-12

Description:
SQL injection vulnerability in wp-includes/query.php in WordPress 2.3.1 and earlier allows remote attackers to execute arbitrary SQL commands via the s parameter, when DB_CHARSET is set to (1) Big5, (2) GBK, or possibly other character set encodings that support a "\" in a multibyte character.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
WordPress Charset SQL injection vulnerability (re-resend)
Abel Cheung
13.12.2007

Type:

CWE-89

(Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection'))

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Wordpress -> Wordpress 

 References:
http://lists.grok.org.uk/pipermail/full-disclosure/2007-December/058999.html
http://securityreason.com/securityalert/3433
http://www.abelcheung.org/advisory/20071210-wordpress-charset.txt
http://www.securityfocus.com/archive/1/484828/100/0/threaded
http://www.securityfocus.com/bid/26795
http://www.securitytracker.com/id?1019071
http://www.vupen.com/english/advisories/2007/4172
https://exchange.xforce.ibmcloud.com/vulnerabilities/38959
https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00079.html
https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00098.html

Copyright 2022, cxsecurity.com

 

Back to Top