Vulnerability CVE-2008-0525


Published: 2008-01-31   Modified: 2012-02-12

Description:
PatchLink Update client for Unix, as used by Novell ZENworks Patch Management Update Agent for Linux/Unix/Mac (LUM) 6.2094 through 6.4102 and other products, allows local users to (1) truncate arbitrary files via a symlink attack on the /tmp/patchlink.tmp file used by the logtrimmer script, and (2) execute arbitrary code via a symlink attack on the /tmp/plshutdown file used by the rebootTask script.

See advisories in our WLB2 database:
Topic
Author
Date
Low
Two vulnerabilities for PatchLink Update Client for Unix.
lcashdol
02.02.2008
Med.
PatchLink Update Unix Client File clobbering vulnerability
Larry W. Cashdol...
03.10.2018

Type:

CWE-59

(Improper Link Resolution Before File Access ('Link Following'))

CVSS2 => (AV:L/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.6/10
6.4/10
3.9/10
Exploit range
Attack complexity
Authentication
Local
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Novell -> Zenworks patch management update agent 
Lumension security -> Patchlink update 

 References:
http://securityreason.com/securityalert/3599
http://support.lumension.com/scripts/rightnow.cfg/php.exe/enduser/std_adp.php?p_faqid=527
http://support.lumension.com/scripts/rightnow.cfg/php.exe/enduser/std_adp.php?p_faqid=528
http://support.lumension.com/scripts/rightnow.cfg/php.exe/enduser/std_adp.php?p_faqid=530
http://www.securityfocus.com/archive/1/487103/100/0/threaded
http://www.securityfocus.com/bid/27458
http://www.securitytracker.com/id?1019272
http://www.vupen.com/english/advisories/2008/0426
https://exchange.xforce.ibmcloud.com/vulnerabilities/39956
https://exchange.xforce.ibmcloud.com/vulnerabilities/39958
https://secure-support.novell.com/KanisaPlatform/Publishing/18/3908994_f.SAL_Public.html

Copyright 2021, cxsecurity.com

 

Back to Top