Vulnerability CVE-2008-1456


Published: 2008-08-13   Modified: 2012-02-12

Description:
Array index vulnerability in the Event System in Microsoft Windows 2000 SP4, XP SP2 and SP3, Server 2003 SP1 and SP2, Vista Gold and SP1, and Server 2008 allows remote authenticated users to execute arbitrary code via a crafted event subscription request that is used to access an array of function pointers.

Type:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:N/AC:L/Au:S/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9/10
10/10
8/10
Exploit range
Attack complexity
Authentication
Remote
Low
Single time
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Microsoft -> Windows-nt 
Microsoft -> Windows 2000 
Microsoft -> Windows 2003 server 
Microsoft -> Windows xp 
Microsoft -> Windows vista 

 References:
http://marc.info/?l=bugtraq&m=121915960406986&w=2
http://www.securityfocus.com/bid/30586
http://www.securitytracker.com/id?1020677
http://www.us-cert.gov/cas/techalerts/TA08-225A.html
http://www.vupen.com/english/advisories/2008/2353
https://docs.microsoft.com/en-us/security-updates/securitybulletins/2008/ms08-049
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A5630

Copyright 2021, cxsecurity.com

 

Back to Top