Vulnerability CVE-2009-0417


Published: 2009-02-10   Modified: 2012-02-13

Description:
Cross-site scripting (XSS) vulnerability in the AgaviWebRouting::gen(null) method in Agavi 0.11 before 0.11.6 and 1.0 before 1.0.0 beta 8 allows remote attackers to inject arbitrary web script or HTML via a crafted URL with certain characters that are not properly handled by web browsers that do not strictly follow RFC 3986, such as Internet Explorer 6 and 7.

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

Vendor: Agavi
Product: Agavi 
Version:
1.0.0
0.11.6
0.11.5
0.11.4
0.11.3
0.11.2
0.11.1
0.11.0

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
http://blog.agavi.org/post/75830918/agavi-1-0-0-beta-8-released-fixes-vulnerability
http://blog.agavi.org/post/75829956/agavi-0-11-6-released-fixes-vulnerability
http://www.securityfocus.com/bid/33826
http://trac.agavi.org/ticket/1019

Copyright 2019, cxsecurity.com

 

Back to Top