Vulnerability CVE-2009-1664


Published: 2009-05-18   Modified: 2012-02-13

Description:
myaccount.php in Easy Scripts Answer and Question Script does not verify the original password before changing passwords, which allows remote attackers to change the password of other users and gain privileges via modified userid, txtpassword, and txtRpassword parameters.

See advisories in our WLB2 database:
Topic
Author
Date
High
Easy Scripts Answer and Question Script Multiple Vulnerabilities
Cyb3r-1sT
18.05.2009

Type:

CWE-287

(Improper Authentication)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Easy-scripts -> Answer and question script 

 References:
http://www.milw0rm.com/exploits/8690

Copyright 2021, cxsecurity.com

 

Back to Top