Vulnerability CVE-2009-2159


Published: 2009-06-22   Modified: 2012-02-13

Description:
backup-database.php in TorrentTrader Classic 1.09 does not require administrative authentication, which allows remote attackers to create and download a backup database by making a direct request and then retrieving a .gz file from backups/.

See advisories in our WLB2 database:
Topic
Author
Date
High
Multiple Vulnerabilities in TorrentTrader Classic 1.09
Waraxe
24.06.2009

Type:

CWE-287

(Improper Authentication)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.4/10
4.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
None
Affected software
Torrenttrader -> Torrenttrader classic 

 References:
http://www.securityfocus.com/archive/1/504294/100/0/threaded
http://www.securityfocus.com/bid/35369
http://www.waraxe.us/advisory-74.html
https://exchange.xforce.ibmcloud.com/vulnerabilities/51147
https://www.exploit-db.com/exploits/8958

Copyright 2020, cxsecurity.com

 

Back to Top