Vulnerability CVE-2009-2386


Published: 2009-07-10   Modified: 2012-02-13

Description:
Insecure method vulnerability in Awingsoft Awakening Winds3D Viewer plugin 3.5.0.0, 3.0.0.5, and possibly other versions allows remote attackers to force the download and execution of arbitrary files via the GetURL method.

Type:

CWE-20

(Improper Input Validation)

Vendor: Awingsoft
Product: Awakening winds3d viewer plugin 
Version: 3.5.0.0; 3.0.0.5;

CVSS2 => (AV:N/AC:M/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9.3/10
10/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete

 References:
http://www.vupen.com/english/advisories/2009/1834
http://www.securityfocus.com/bid/35595
http://www.coresecurity.com/content/winds3d-viewer-advisory
http://secunia.com/advisories/35764

Copyright 2019, cxsecurity.com

 

Back to Top