Vulnerability CVE-2009-3027


Published: 2009-12-11   Modified: 2012-02-13

Description:
VRTSweb.exe in VRTSweb in Symantec Backup Exec Continuous Protection Server (CPS) 11d, 12.0, and 12.5; Veritas NetBackup Operations Manager (NOM) 6.0 GA through 6.5.5; Veritas Backup Reporter (VBR) 6.0 GA through 6.6; Veritas Storage Foundation (SF) 3.5; Veritas Storage Foundation for Windows High Availability (SFWHA) 4.3MP2, 5.0, 5.0RP1a, 5.0RP2, 5.1, and 5.1AP1; Veritas Storage Foundation for High Availability (SFHA) 3.5; Veritas Storage Foundation for Oracle (SFO) 4.1, 5.0, and 5.0.1; Veritas Storage Foundation for DB2 4.1 and 5.0; Veritas Storage Foundation for Sybase 4.1 and 5.0; Veritas Storage Foundation for Oracle Real Application Cluster (SFRAC) 3.5, 4.0, 4.1, and 5.0; Veritas Storage Foundation Manager (SFM) 1.0, 1.0 MP1, 1.1, 1.1.1Ux, 1.1.1Win, and 2.0; Veritas Cluster Server (VCS) 3.5, 4.0, 4.1, and 5.0; Veritas Cluster Server One (VCSOne) 2.0, 2.0.1, and 2.0.2; Veritas Application Director (VAD) 1.1 and 1.1 Platform Expansion; Veritas Cluster Server Management Console (VCSMC) 5.1, 5.5, and 5.5.1; Veritas Storage Foundation Cluster File System (SFCFS) 3.5, 4.0, 4.1, and 5.0; Veritas Storage Foundation Cluster File System for Oracle RAC (SFCFS RAC) 5.0; Veritas Command Central Storage (CCS) 4.x, 5.0, and 5.1; Veritas Command Central Enterprise Reporter (CC-ER) 5.0 GA, 5.0 MP1, 5.0 MP1RP1, and 5.1; Veritas Command Central Storage Change Manager (CC-SCM) 5.0 and 5.1; and Veritas MicroMeasure 5.0 does not properly validate authentication requests, which allows remote attackers to trigger the unpacking of a WAR archive, and execute arbitrary code in the contained files, via crafted data to TCP port 14300.

See advisories in our WLB2 database:
Topic
Author
Date
High
Symantec Multiple Products VRTSweb.exe Remote Code Execution Vulnerability
ZDI
15.12.2009

Type:

CWE-287

(Improper Authentication)

Vendor: Symantec
Product: Veritas netbackup reporter 
Version: 6.6; 6.0_ga;
Product: Veritas netbackup operations manager 
Version: 6.5.5; 6.0_ga;
Product: Veritas cluster server management console 
Version:
5.5.1
5.5
5.1
Product: Veritas storage foundation for windows high availability 
Version:
5.1ap1
5.1
5.0rp2
5.0rp1a
5.0
4.3mp2
Product: Veritas command central storage 
Version:
5.1
5.0
4.x
Product: Veritas command central storage change manager 
Version: 5.1; 5.0;
Product: Veritas command central enterprise reporter 
Version:
5.1
5.0_ga
5.0mp1rp1
5.0mp1
Product: Veritas storage foundation for oracle 
Version:
5.0.1
5.0
4.1
Product: Veritas storage foundation cluster file system for oracle rac 
Version: 5.0;
Product: Veritas storage foundation for sybase 
Version: 5.0; 4.1;
Product: Veritas storage foundation for db2 
Version: 5.0; 4.1;
Product: Veritas storage foundation cluster file system 
Version:
5.0
4.1
4.0
3.5
Product: Veritas micromeasure 
Version: 5.0;
Product: Veritas storage foundation for oracle real application cluster 
Version:
5.0
4.1
4.0
3.5
Product: Veritas cluster server 
Version:
5.0
4.1
4.0
3.5
Product: Veritas storae foundation 
Version: 3.5_onwards;
Product: Veritas storage foundation 
Version: 3.5;
Product: Veritas storage foundation for high availability 
Version: 3.5;
Product: Veritas cluster server one 
Version:
2.0.2
2.0.1
2.0
Product: Veritas storage foundation manager 
Version:
2.0
1.1.1win
1.1.1ux
1.1
1.0mp1
1.0
Product: Backup exec continuous protection server 
Version:
12.5
12.0
11d
Product: Veritas backup exec 
Version:
12.5
12.0
11d
Product: Veritas application director 
Version: 1.1;

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
10/10
10/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete

 References:
http://marc.info/?l=bugtraq&m=126046186917330&w=2
http://securitytracker.com/id?1023309
http://securitytracker.com/id?1023312
http://seer.entsupport.symantec.com/docs/336988.htm
http://seer.entsupport.symantec.com/docs/337279.htm
http://seer.entsupport.symantec.com/docs/337293.htm
http://seer.entsupport.symantec.com/docs/337392.htm
http://seer.entsupport.symantec.com/docs/337859.htm
http://seer.entsupport.symantec.com/docs/337930.htm
http://www.securityfocus.com/archive/1/508358/100/0/threaded
http://www.securityfocus.com/bid/37012
http://www.securitytracker.com/id?1023311
http://www.securitytracker.com/id?1023313
http://www.securitytracker.com/id?1023318
http://www.symantec.com/security_response/securityupdates/detail.jsp?fid=security_advisory&pvid=security_advisory&year=2009&suid=20091209_00
http://www.vupen.com/english/advisories/2009/3467
http://www.vupen.com/english/advisories/2009/3483
http://www.zerodayinitiative.com/advisories/ZDI-09-098/
https://exchange.xforce.ibmcloud.com/vulnerabilities/54665
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A7986

Related CVE
CVE-2019-9694
Symantec Endpoint Encryption prior to SEE 11.2.1 MP1 may be susceptible to a Privilege Escalation vulnerability, which is a type of issue whereby an attacker may attempt to compromise the software application to gain elevated access to resources that...
CVE-2019-9696
Symantec VIP Enterprise Gateway (all versions) may be susceptible to a cross-site scripting (XSS) exploit, which is a type of issue that can enable attackers to inject client-side scripts into web pages viewed by other users. A cross-site scripting v...
CVE-2018-18364
Symantec Ghost Solution Suite (GSS) versions prior to 3.3 RU1 may be susceptible to a DLL hijacking vulnerability, which is a type of issue whereby a potential attacker attempts to execute unexpected code on your machine. This occurs via placement of...
CVE-2018-12245
Symantec Endpoint Protection prior to 14.2 MP1 may be susceptible to a DLL Preloading vulnerability, which in this case is an issue that can occur when an application being installed unintentionally loads a DLL provided by a potential attacker. Note ...
CVE-2018-12239
Norton prior to 22.15; Symantec Endpoint Protection (SEP) prior to 12.1.7454.7000 & 14.2; Symantec Endpoint Protection Small Business Edition (SEP SBE) prior to NIS-22.15.1.8 & SEP-12.1.7454.7000; and Symantec Endpoint Protection Cloud (SEP Cloud) pr...
CVE-2018-12238
Norton prior to 22.15; Symantec Endpoint Protection (SEP) prior to 12.1.7454.7000 & 14.2; Symantec Endpoint Protection Small Business Edition (SEP SBE) prior to NIS-22.15.1.8 & SEP-12.1.7454.7000; and Symantec Endpoint Protection Cloud (SEP Cloud) pr...
CVE-2018-12243
The Symantec Messaging Gateway product prior to 10.6.6 may be susceptible to a XML external entity (XXE) exploit, which is a type of issue where XML input containing a reference to an external entity is processed by a weakly configured XML parser. Th...
CVE-2018-12242
The Symantec Messaging Gateway product prior to 10.6.6 may be susceptible to an authentication bypass exploit, which is a type of issue that can allow attackers to potentially circumvent security mechanisms currently in place and gain access to the s...

Copyright 2019, cxsecurity.com

 

Back to Top