Vulnerability CVE-2009-4321


Published: 2009-12-14   Modified: 2012-02-13

Description:
extras/curltest.php in Zen Cart 1.3.8 and 1.3.8a, and possibly other versions, allows remote attackers to read arbitrary files via a file:// URI. NOTE: some of these details are obtained from third party information.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
Zen Cart local file disclosure vulnerability
Bogdan Calin
16.12.2009

Type:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Zen-cart -> Zen cart 

 References:
http://www.acunetix.com/blog/websecuritynews/acusensor-curl-and-zen-cart/
http://www.securityfocus.com/archive/1/508340/100/0/threaded
http://www.securityfocus.com/bid/37283
http://www.vupen.com/english/advisories/2009/3474
http://www.zen-cart.com/forum/showthread.php?t=142784
https://exchange.xforce.ibmcloud.com/vulnerabilities/54687

Copyright 2022, cxsecurity.com

 

Back to Top