Vulnerability CVE-2010-0277


Published: 2010-01-09   Modified: 2012-02-13

Description:
slp.c in the MSN protocol plugin in libpurple in Pidgin before 2.6.6, including 2.6.4, and Adium 1.3.8 allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly have unspecified other impact via a malformed MSNSLP INVITE request in an SLP message, a different issue than CVE-2010-0013.

Type:

CWE-399

(Resource Management Errors)

Vendor: Pidgin
Product: Pidgin 
Version:
2.6.5
2.6.4
2.6.2
2.6.1
2.6.0
2.5.9
2.5.8
2.5.7
2.5.6
2.5.5
2.5.4
2.5.3
2.5.2
2.5.1
2.5.0
2.4.3
2.4.2
2.4.1
2.4.0
2.3.1
2.3.0
2.2.2
2.2.1
2.2.0
2.1.1
2.1.0
2.0.2
2.0.1
2.0.0
Vendor: Adium
Product: Adium 
Version: 1.3.8;

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial

 References:
https://rhn.redhat.com/errata/RHSA-2010-0115.html
https://bugzilla.redhat.com/show_bug.cgi?id=554335
http://www.vupen.com/english/advisories/2010/2693
http://www.vupen.com/english/advisories/2010/1020
http://www.vupen.com/english/advisories/2010/0413
http://www.ubuntu.com/usn/USN-902-1
http://www.securityfocus.com/bid/38294
http://www.openwall.com/lists/oss-security/2010/01/07/2
http://www.mandriva.com/security/advisories?name=MDVSA-2010:085
http://www.mandriva.com/security/advisories?name=MDVSA-2010:041
http://secunia.com/advisories/41868
http://secunia.com/advisories/38915
http://secunia.com/advisories/38712
http://secunia.com/advisories/38658
http://secunia.com/advisories/38640
http://secunia.com/advisories/38563
http://pidgin.im/news/security/?id=43
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9421
http://lists.opensuse.org/opensuse-security-announce/2010-03/msg00004.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-February/035409.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-February/035347.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-February/035332.html
http://events.ccc.de/congress/2009/Fahrplan/events/3596.en.html
http://developer.pidgin.im/wiki/ChangeLog
http://blogs.sun.com/security/entry/cve_2010_0277_malformed_msn

Related CVE
CVE-2010-0013
Directory traversal vulnerability in slp.c in the MSN protocol plugin in libpurple in Pidgin 2.6.4 and Adium 1.3.8 allows remote attackers to read arbitrary files via a .. (dot dot) in an application/x-msnmsgrp2p MSN emoticon (aka custom smiley) requ...
CVE-2009-3615
The OSCAR protocol plugin in libpurple in Pidgin before 2.6.3 and Adium before 1.3.7 allows remote attackers to cause a denial of service (application crash) via crafted contact-list data for (1) ICQ and possibly (2) AIM, as demonstrated by the SIM I...
CVE-2009-2694
The msn_slplink_process_msg function in libpurple/protocols/msn/slplink.c in libpurple, as used in Pidgin (formerly Gaim) before 2.5.9 and Adium 1.3.5 and earlier, allows remote attackers to execute arbitrary code or cause a denial of service (memory...
CVE-2008-7190
Unspecified vulnerability in Adium before 1.2 has unknown impact and attack vectors related to javascript: URLs, possibly cross-site scripting (XSS).
CVE-2008-2927
Multiple integer overflows in the msn_slplink_process_msg functions in the MSN protocol handler in (1) libpurple/protocols/msn/slplink.c and (2) libpurple/protocols/msnp9/slplink.c in Pidgin before 2.4.3 and Adium before 1.3 allow remote attackers to...

Copyright 2019, cxsecurity.com

 

Back to Top