Vulnerability CVE-2010-1185


Published: 2010-03-29   Modified: 2012-02-13

Description:
Stack-based buffer overflow in serv.exe in SAP MaxDB 7.4.3.32, and 7.6.0.37 through 7.6.06 allows remote attackers to execute arbitrary code via an invalid length parameter in a handshake packet to TCP port 7210. NOTE: some of these details are obtained from third party information.

See advisories in our WLB2 database:
Topic
Author
Date
High
SAP MaxDB Malformed Handshake Request Remote Code Execution
ZDI
01.04.2010

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
10/10
10/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
SAP -> Maxdb 

 References:
http://www.securityfocus.com/archive/1/510125/100/0/threaded
http://www.securityfocus.com/bid/38769
http://www.securitytracker.com/id?1023719
http://www.vupen.com/english/advisories/2010/0643
http://www.zerodayinitiative.com/advisories/ZDI-10-032/
https://exchange.xforce.ibmcloud.com/vulnerabilities/56950

Copyright 2020, cxsecurity.com

 

Back to Top