Vulnerability CVE-2010-2352


Published: 2010-06-21   Modified: 2012-02-13

Description:
The Node Reference module in Content Construction Kit (CCK) module 5.x before 5.x-1.11 and 6.x before 6.x-2.7 for Drupal does not perform access checks before displaying referenced nodes, which allows remote attackers to read controlled nodes.

Type:

CWE-20

(Improper Input Validation)

Vendor: Karen stevenson
Product: CCK 
Version:
6.x-2.6
6.x-2.5
6.x-2.4
6.x-2.3
6.x-2.2
6.x-2.1
6.x-2.0
5.x-1.x
5.x-1.7
5.x-1.3
5.x-1.2
5.x-1.1
5.x-1.0
Vendor: Yves chedemois
Product: CCK 
Version:
5.x-1.9
5.x-1.8
5.x-1.6-1
5.x-1.6
5.x-1.5
5.x-1.4
5.x-1.10

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None

 References:
http://drupal.org/node/829566
http://xforce.iss.net/xforce/xfdb/59515
http://www.vupen.com/english/advisories/2010/1546
http://secunia.com/advisories/40318
http://secunia.com/advisories/40243
http://osvdb.org/65615
http://lists.fedoraproject.org/pipermail/package-announce/2010-June/043191.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-June/043172.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-June/043100.html

Copyright 2019, cxsecurity.com

 

Back to Top