Vulnerability CVE-2010-4337


Published: 2011-01-14   Modified: 2012-02-13

Description:
The configure script in gnash 0.8.8 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/gnash-configure-errors.$$, (2) /tmp/gnash-configure-warnings.$$, or (3) /tmp/gnash-configure-recommended.$$ files.

CVSS2 => (AV:L/AC:M/Au:N/C:N/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
3.3/10
4.9/10
3.4/10
Exploit range
Attack complexity
Authentication
Local
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
Partial
Affected software
GNU -> Gnash 

 References:
http://www.securityfocus.com/bid/45102
http://www.osvdb.org/69533
http://www.debian.org/security/2012/dsa-2435
http://secunia.com/advisories/48466
http://secunia.com/advisories/42416
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=605419

Copyright 2021, cxsecurity.com

 

Back to Top