Vulnerability CVE-2010-5085


Published: 2012-02-14   Modified: 2012-02-15

Description:
Multiple cross-site request forgery (CSRF) vulnerabilities in admin/update_user in Hulihan Amethyst 0.1.5, and possibly earlier, allow remote attackers to hijack the authentication of administrators for requests that (1) change the administrative password or (2) change the site's configuration.

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Hulihanapplications -> Amethyst 

 References:
http://dev.hulihanapplications.com/issues/show/208
http://marc.info/?l=bugtraq&m=128104795219200&w=2
http://www.htbridge.ch/advisory/xsrf_csrf_in_amethyst.html
http://www.vupen.com/english/advisories/2010/2022
https://exchange.xforce.ibmcloud.com/vulnerabilities/60947

Copyright 2021, cxsecurity.com

 

Back to Top