Vulnerability CVE-2011-4328


Published: 2012-06-15   Modified: 2012-06-16

Description:
plugin/npapi/plugin.cpp in Gnash before 0.8.10 uses weak permissions (world readable) for cookie files with predictable names in /tmp, which allows local users to obtain sensitive information.

Type:

CWE-264

(Permissions, Privileges, and Access Controls)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
GNU -> Gnash 

 References:
https://bugzilla.redhat.com/show_bug.cgi?id=755518
http://www.securityfocus.com/bid/50747
http://www.osvdb.org/77243
http://www.openwall.com/lists/oss-security/2011/11/21/7
http://www.openwall.com/lists/oss-security/2011/11/21/12
http://www.debian.org/security/2012/dsa-2435
http://secunia.com/advisories/48466
http://secunia.com/advisories/48325
http://lists.opensuse.org/opensuse-updates/2012-03/msg00026.html
http://lists.opensuse.org/opensuse-updates/2012-03/msg00003.html
http://git.savannah.gnu.org/gitweb/?p=gnash.git;a=commitdiff;h=fa481c116e65ccf9137c7ddc8abc3cf05dc12f55
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=649384

Copyright 2021, cxsecurity.com

 

Back to Top