Vulnerability CVE-2012-0984


Published: 2014-09-11

Description:
Multiple cross-site scripting (XSS) vulnerabilities in XOOPS before 2.5.5 allow remote attackers to inject arbitrary web script or HTML via the (1) to_userid parameter to modules/pm/pmlite.php or the (2) current_file, (3) imgcat_id, or (4) target parameter to class/xoopseditor/tinymce/tinymce/jscripts/tiny_mce/plugins/xoopsimagemanager/xoopsimagebrowser.php.

See advisories in our WLB2 database:
Topic
Author
Date
Low
XOOPS 2.5.4 Cross Site Scripting
High-Tech Bridge...
19.04.2012

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
Xoops -> Xoops 

 References:
http://xoops.org/modules/news/article.php?storyid=6284
https://www.htbridge.com/advisory/multiple_vulnerabilities_in_xoops.html
http://xforce.iss.net/xforce/xfdb/75024
http://www.securityfocus.com/bid/53143
http://www.exploit-db.com/exploits/18753
http://secunia.com/advisories/48887
http://packetstormsecurity.org/files/111958/XOOPS-2.5.4-Cross-Site-Scripting.html
http://osvdb.org/81213
http://osvdb.org/81212
http://archives.neohapsis.com/archives/bugtraq/2012-04/0128.html

Copyright 2022, cxsecurity.com

 

Back to Top