Vulnerability CVE-2012-1011


Published: 2012-02-07   Modified: 2012-02-13

Description:
actions.php in the AllWebMenus plugin 1.1.8 for WordPress allows remote attackers to bypass intended access restrictions to upload and execute arbitrary PHP code by setting the HTTP_REFERER to a certain value, then uploading a ZIP file containing a PHP file, then accessing it via a direct request to the file in an unspecified directory.

See advisories in our WLB2 database:
Topic
Author
Date
High
AllWebMenus < 1.1.9 WordPress Menu Plugin Arbitrary File Upload
6Scan
23.01.2012

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Likno -> Allwebmenus plugin 

 References:
http://wordpress.org/extend/plugins/allwebmenus-wordpress-menu-plugin/changelog/
http://xforce.iss.net/xforce/xfdb/72640
http://www.securityfocus.com/bid/51615
http://www.exploit-db.com/exploits/18407
http://secunia.com/advisories/47659
http://archives.neohapsis.com/archives/bugtraq/2012-01/0137.html

Copyright 2020, cxsecurity.com

 

Back to Top