Vulnerability CVE-2012-2065


Published: 2012-09-04   Modified: 2012-09-05

Description:
Cross-site scripting (XSS) vulnerability in the Language Icons module 6.x-2.x before 6.x-2.1 and 7.x-1.x before 7.x-1.0 for Drupal allows remote authenticated users with administer languages permissions to inject arbitrary web script or HTML via unspecified vectors.

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

Vendor: Freso
Product: Languageicons 
Version:
7.x-1.x
7.x-1.0
6.x-2.x
6.x-2.1
6.x-2.0

CVSS2 => (AV:N/AC:M/Au:S/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
3.5/10
2.9/10
6.8/10
Exploit range
Attack complexity
Authentication
Remote
Medium
Single time
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
http://drupal.org/node/1482428
http://drupal.org/node/1482144
http://drupal.org/node/1482136
http://www.securityfocus.com/bid/52499
http://www.osvdb.org/80070
http://www.openwall.com/lists/oss-security/2012/04/07/1
http://secunia.com/advisories/48405
http://drupalcode.org/project/languageicons.git/commit/e3f3f1f
http://drupalcode.org/project/languageicons.git/commit/be620bb

Copyright 2019, cxsecurity.com

 

Back to Top