Vulnerability CVE-2012-6573


Published: 2013-06-25

Description:
Cross-site scripting (XSS) vulnerability in the Apache Solr Autocomplete module 6.x-1.x before 6.x-1.4 and 7.x-1.x before 7.x-1.3 for Drupal allows remote attackers to inject arbitrary web script or HTML via vectors involving autocomplete results.

See advisories in our WLB2 database:
Topic
Author
Date
Low
Drupal 7.x Apache Solr Autocomplete Cross Site Scripting
Alejandro Garza
27.06.2013

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

Vendor: Alejandro garza
Product: Apache solr autocomplete 
Version:
7.x-1.x-dev
7.x-1.2
7.x-1.1
7.x-1.0
6.x-1.x-dev
6.x-1.3
6.x-1.2
6.x-1.1
6.x-1.0

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
https://drupal.org/node/1762734
https://drupal.org/node/1762686
https://drupal.org/node/1762684
http://xforce.iss.net/xforce/xfdb/78153
http://www.securityfocus.com/bid/55290
http://secunia.com/advisories/50443
http://seclists.org/fulldisclosure/2013/Jun/212
http://osvdb.org/85062

Copyright 2019, cxsecurity.com

 

Back to Top