Vulnerability CVE-2013-4852


Published: 2013-08-19   Modified: 2013-08-20

Description:
Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

See advisories in our WLB2 database:
Topic
Author
Date
High
PuTTY 0.62 Heap Overflow
Gergely Eberhard...
06.08.2013

Type:

CWE-189

(Numeric Errors)

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Winscp -> Winscp 
Simon tatham -> Putty 
Putty -> Putty 
Opensuse -> Opensuse 
Novell -> Opensuse 
Debian -> Debian linux 

 References:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=718779
http://lists.opensuse.org/opensuse-updates/2013-08/msg00035.html
http://lists.opensuse.org/opensuse-updates/2013-08/msg00041.html
http://svn.tartarus.org/sgt?view=revision&sortby=date&revision=9896
http://winscp.net/tracker/show_bug.cgi?id=1017
http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-signature-stringlen.html
http://www.debian.org/security/2013/dsa-2736
http://www.search-lab.hu/advisories/secadv-20130722

Copyright 2022, cxsecurity.com

 

Back to Top