Vulnerability CVE-2013-6837


Published: 2013-12-18   Modified: 2013-12-19

Description:
Cross-site scripting (XSS) vulnerability in the setTimeout function in js/jquery.prettyPhoto.js in prettyPhoto 3.1.4 and earlier allows remote attackers to inject arbitrary web script or HTML via a crafted PATH_INTO to the default URI.

See advisories in our WLB2 database:
Topic
Author
Date
Low
WordPress Pretty Photo Cross Site Scripting
Rafay Baloch
21.11.2013

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
No-margin-for-errors -> Prettyphoto 

 References:
http://cxsecurity.com/issue/WLB-2013110149
http://themeforest.net/forums/thread/security-vulnerability-affecting-prettyphoto-jquery-script/181180
http://themeforest.net/item/udesign-responsive-wordpress-theme/253220
http://www.no-margin-for-errors.com/projects/prettyphoto-jquery-lightbox-clone/
http://www.perucrack.net/2014/07/haciendo-un-xss-en-plugin-prettyphoto.html
http://www.rafayhackingarticles.net/2013/05/kali-linux-dom-based-xss-writeup.html
https://github.com/Duncaen/prettyphoto/commit/3ef0ddfefebbcc6bbe9245f9cea87e26838e9bbc

Copyright 2021, cxsecurity.com

 

Back to Top