Vulnerability CVE-2014-2718


Published: 2014-11-04   Modified: 2014-11-05

Description:
ASUS RT-AC68U, RT-AC66R, RT-AC66U, RT-AC56R, RT-AC56U, RT-N66R, RT-N66U, RT-N56R, RT-N56U, and possibly other RT-series routers before firmware 3.0.0.4.376.x do not verify the integrity of firmware (1) update information or (2) downloaded updates, which allows man-in-the-middle (MITM) attackers to execute arbitrary code via a crafted image.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
ASUS wireless router updates are vulnerable to a MITM attack
David
29.10.2014

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:C/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.1/10
6.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Complete
None
Affected software
T-mobile -> Tm-ac1900 
ASUS -> Rt firmware 
ASUS -> Rt series firmware 

 References:
https://support.t-mobile.com/docs/DOC-21994
http://xforce.iss.net/xforce/xfdb/98316
http://www.securityfocus.com/bid/70791
http://seclists.org/fulldisclosure/2014/Oct/122
http://packetstormsecurity.com/files/128904/ASUS-Router-Man-In-The-Middle.html
http://dnlongen.blogspot.com/2014/10/CVE-2014-2718-Asus-RT-MITM.html

Copyright 2022, cxsecurity.com

 

Back to Top