Vulnerability CVE-2014-7138


Published: 2014-10-16   Modified: 2015-01-07

Description:
Cross-site scripting (XSS) vulnerability in the Google Calendar Events plugin before 2.0.4 for WordPress allows remote attackers to inject arbitrary web script or HTML via the gce_feed_ids parameter in a gce_ajax action to wp-admin/admin-ajax.php.

See advisories in our WLB2 database:
Topic
Author
Date
Low
WordPress Google Calendar Events 2.0.1 Cross Site Scripting
High-Tech Bridge...
10.10.2014

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

Vendor: Google
Product: Calendar events 
Version:
2.0.3.1
2.0.3
2.0.2
2.0.1
2.0.0
Vendor: Phil derksen
Product: Google calendar events 
Version: 2.0.3.1;
Vendor: Google calendar events project
Product: Google calendar events 
Version: 2.0.3.1;

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
https://www.htbridge.com/advisory/HTB23235
https://wordpress.org/plugins/google-calendar-events/changelog
https://github.com/pderksen/WP-Google-Calendar-Events/commit/a701ceeb410bdda9d96c9d3d12104630df5d5b43
http://xforce.iss.net/xforce/xfdb/96867
http://www.securityfocus.com/bid/70370
http://www.securityfocus.com/archive/1/archive/1/533640/100/0/threaded
http://packetstormsecurity.com/files/128626/WordPress-Google-Calendar-Events-2.0.1-Cross-Site-Scripting.html

Copyright 2017, cxsecurity.com