Vulnerability CVE-2014-8318


Published: 2014-10-17

Description:
Cross-site scripting (XSS) vulnerability in the Webform module 6.x-3.x before 6.x-3.20, 7.x-3.x before 7.x-3.20, and 7.x-4.x before 7.x-4.0-beta2 for Drupal allows remote authenticated users with certain permissions to inject arbitrary web script or HTML via a field label title, when two fields have the same form_key.

Vendor: Webform
Product: Webform 
Version:
7.x-4.0
7.x-3.9
7.x-3.8
7.x-3.7
7.x-3.6
7.x-3.5
7.x-3.4
7.x-3.3
7.x-3.2
7.x-3.19
7.x-3.18
7.x-3.17
7.x-3.16
7.x-3.15
7.x-3.14
7.x-3.13
7.x-3.12
7.x-3.11
7.x-3.10
7.x-3.1
7.x-3.0
6.x-3.9
6.x-3.8
6.x-3.7
6.x-3.6
6.x-3.5
6.x-3.4
6.x-3.3
6.x-3.2
6.x-3.19
6.x-3.18
6.x-3.17
6.x-3.16
See more versions on NVD
Vendor: Drupal
Product: Webform module 
Version:
7.x-4.0
7.x-3.9
7.x-3.8
7.x-3.7
7.x-3.6
7.x-3.5
7.x-3.4
7.x-3.3
7.x-3.2
7.x-3.19
7.x-3.18
7.x-3.17
7.x-3.16
7.x-3.15
7.x-3.14
7.x-3.13
7.x-3.12
7.x-3.11
7.x-3.10
7.x-3.1
7.x-3.0
6.x-3.9
6.x-3.8
6.x-3.7
6.x-3.6
6.x-3.5
6.x-3.4
6.x-3.3
6.x-3.2
6.x-3.19
6.x-3.18
6.x-3.17
6.x-3.16
See more versions on NVD
Vendor: Webform project
Product: Webform 
Version:
7.x-4.0
7.x-3.9
7.x-3.8
7.x-3.7
7.x-3.6
7.x-3.5
7.x-3.4
7.x-3.3
7.x-3.2
7.x-3.19
7.x-3.18
7.x-3.17
7.x-3.16
7.x-3.15
7.x-3.14
7.x-3.13
7.x-3.12
7.x-3.11
7.x-3.10
7.x-3.1
7.x-3.0
6.x-3.9
6.x-3.8
6.x-3.7
6.x-3.6
6.x-3.5
6.x-3.4
6.x-3.3
6.x-3.2
6.x-3.19
6.x-3.18
6.x-3.17
6.x-3.16
6.x-3.15
See more versions on NVD

CVSS2 => (AV:N/AC:M/Au:S/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
3.5/10
2.9/10
6.8/10
Exploit range
Attack complexity
Authentication
Remote
Medium
Single time
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
http://www.securityfocus.com/bid/65528
https://drupal.org/node/2194671
https://exchange.xforce.ibmcloud.com/vulnerabilities/91156
https://www.drupal.org/node/2194175
https://www.drupal.org/node/2194181
https://www.drupal.org/node/2194183

Related CVE
CVE-2015-4374
Cross-site scripting (XSS) vulnerability in the Webform module before 6.x-3.23, 7.x-3.x before 7.x-3.23, and 7.x-4.x before 7.x-4.5 for Drupal allows remote authenticated users with certain permissions to inject arbitrary web script or HTML via a com...
CVE-2015-4357
Cross-site scripting (XSS) vulnerability in the Webform module before 6.x-3.22, 7.x-3.x before 7.x-3.22, and 7.x-4.x before 7.x-4.4 for Drupal allows remote authenticated users with certain permissions to inject arbitrary web script or HTML via a nod...
CVE-2015-4356
Cross-site scripting (XSS) vulnerability in the view-based webform results table in the Webform module 7.x-4.x before 7.x-4.4 for Drupal allows remote authenticated users with certain permissions to inject arbitrary web script or HTML via a webform.

Copyright 2019, cxsecurity.com

 

Back to Top