Vulnerability CVE-2015-1589


Published: 2015-02-23   Modified: 2015-02-24

Description:
Directory traversal vulnerability in arCHMage 0.2.4 allows remote attackers to write to arbitrary files via a .. (dot dot) in a CHM file.

Type:

CWE-22

(Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'))

Vendor: Archmage project
Product: Archmage 
Version: 0.2.4;

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776164
http://xforce.iss.net/xforce/xfdb/100879
http://www.openwall.com/lists/oss-security/2015/02/12/9
http://www.openwall.com/lists/oss-security/2015/02/12/16

Copyright 2017, cxsecurity.com