Vulnerability CVE-2015-3246


Published: 2015-08-11

Description:
libuser before 0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper program in the usermode package, directly modifies /etc/passwd, which allows local users to cause a denial of service (inconsistent file state) by causing an error during the modification. NOTE: this issue can be combined with CVE-2015-3245 to gain privileges.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
userhelper/libuser Multiple vulns
Qualys
24.07.2015
Med.
Libuser roothelper Privilege Escalation
Brendan Coles
14.05.2018

Type:

CWE-264

(Permissions, Privileges, and Access Controls)

CVSS2 => (AV:L/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.2/10
10/10
3.9/10
Exploit range
Attack complexity
Authentication
Local
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Redhat -> Libuser 

 References:
http://lists.fedoraproject.org/pipermail/package-announce/2015-August/163044.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-July/162947.html
http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00000.html
http://rhn.redhat.com/errata/RHSA-2015-1482.html
http://rhn.redhat.com/errata/RHSA-2015-1483.html
http://www.securityfocus.com/bid/76022
http://www.securitytracker.com/id/1033040
https://access.redhat.com/articles/1537873
https://www.exploit-db.com/exploits/44633/
https://www.qualys.com/2015/07/23/cve-2015-3245-cve-2015-3246/cve-2015-3245-cve-2015-3246.txt

Copyright 2020, cxsecurity.com

 

Back to Top