Vulnerability CVE-2015-5162


Published: 2016-10-07

Description:
The image parser in OpenStack Cinder 7.0.2 and 8.0.0 through 8.1.1; Glance before 11.0.1 and 12.0.0; and Nova before 12.0.4 and 13.0.0 does not properly limit qemu-img calls, which might allow attackers to cause a denial of service (memory and disk consumption) via a crafted disk image.

Type:

CWE-399

(Resource Management Errors)

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.8/10
6.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Complete
Affected software
Openstack -> Cinder 
Openstack -> Glance 
Openstack -> NOVA 

 References:
http://rhn.redhat.com/errata/RHSA-2016-2923.html
http://rhn.redhat.com/errata/RHSA-2016-2991.html
http://rhn.redhat.com/errata/RHSA-2017-0153.html
http://rhn.redhat.com/errata/RHSA-2017-0156.html
http://rhn.redhat.com/errata/RHSA-2017-0165.html
http://rhn.redhat.com/errata/RHSA-2017-0282.html
http://www.openwall.com/lists/oss-security/2016/10/06/8
http://www.securityfocus.com/bid/76849
https://launchpad.net/bugs/1449062

Copyright 2022, cxsecurity.com

 

Back to Top