Vulnerability CVE-2016-4463


Published: 2016-07-08

Description:
Stack-based buffer overflow in Apache Xerces-C++ before 3.1.4 allows context-dependent attackers to cause a denial of service via a deeply nested DTD.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial
Affected software
Debian -> Debian linux 
Apache -> Xerces-c++ 

 References:
http://lists.opensuse.org/opensuse-updates/2016-07/msg00053.html
http://lists.opensuse.org/opensuse-updates/2016-09/msg00013.html
http://packetstormsecurity.com/files/137714/Apache-Xerces-C-XML-Parser-Crash.html
http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
http://www.securityfocus.com/archive/1/538784/100/0/threaded
http://www.securityfocus.com/bid/91501
http://www.securitytracker.com/id/1036211
http://xerces.apache.org/xerces-c/secadv/CVE-2016-4463.txt
https://access.redhat.com/errata/RHSA-2018:3335
https://access.redhat.com/errata/RHSA-2018:3506
https://access.redhat.com/errata/RHSA-2018:3514
https://issues.apache.org/jira/browse/XERCESC-2069
https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=10510&version=12336069
https://www.debian.org/security/2016/dsa-3610

Copyright 2021, cxsecurity.com

 

Back to Top