Vulnerability CVE-2016-5746


Published: 2016-09-26

Description:
libstorage, libstorage-ng, and yast-storage improperly store passphrases for encrypted storage devices in a temporary file on disk, which might allow local users to obtain sensitive information by reading the file, as demonstrated by /tmp/libstorage-XXXXXX/pwdf.

Type:

CWE-Other

CVSS2 => (AV:L/AC:H/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
1.2/10
2.9/10
1.9/10
Exploit range
Attack complexity
Authentication
Local
High
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
YAST -> Yast-storage 
Opensuse -> Libstorage 
Opensuse -> Libstorage-ng 
Opensuse -> LEAP 
Novell -> LEAP 

 References:
http://lists.opensuse.org/opensuse-updates/2016-09/msg00032.html
http://www.securityfocus.com/bid/93169
https://bugzilla.suse.com/show_bug.cgi?id=986971
https://github.com/openSUSE/libstorage-ng/pull/123
https://github.com/openSUSE/libstorage/pull/162
https://github.com/openSUSE/libstorage/pull/163
https://github.com/yast/yast-storage/pull/223
https://github.com/yast/yast-storage/pull/224
https://github.com/yast/yast-storage/pull/226
https://github.com/yast/yast-storage/pull/227

Copyright 2022, cxsecurity.com

 

Back to Top