Vulnerability CVE-2016-7099


Published: 2016-10-10

Description:
The tls.checkServerIdentity function in Node.js 0.10.x before 0.10.47, 0.12.x before 0.12.16, 4.x before 4.6.0, and 6.x before 6.7.0 does not properly handle wildcards in name fields of X.509 certificates, which allows man-in-the-middle attackers to spoof servers via a crafted certificate.

Type:

CWE-19

(Data Handling)

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
SUSE -> Linux enterprise 
Nodejs -> Node.js 

 References:
http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00013.html
http://rhn.redhat.com/errata/RHSA-2017-0002.html
http://www.securityfocus.com/bid/93191
https://github.com/nodejs/node/commit/743f0c916469f3129dfae406fa104dc46782e20b
https://nodejs.org/en/blog/vulnerability/september-2016-security-releases/

Copyright 2021, cxsecurity.com

 

Back to Top