Vulnerability CVE-2017-16093


Published: 2018-06-06   Modified: 2018-06-07

Description:
cyber-js is a simple http server. A cyberjs server is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.

Type:

CWE-22

(Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'))

Vendor: Cyber-js project
Product: Cyber-js 

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None

 References:
https://github.com/JacksonGL/NPM-Vuln-PoC/tree/master/directory-traversal/cyber-js
https://nodesecurity.io/advisories/347

Copyright 2018, cxsecurity.com

 

Back to Top