Vulnerability CVE-2017-17773


Published: 2018-03-15   Modified: 2018-03-16

Description:
In Snapdragon Automobile, Snapdragon Wearable and Snapdragon Mobile MDM9206,MDM9607,MDM9650,SD 210/SD 212/SD 205,SD 400,SD 410/12,SD 425,SD 430,SD 450,SD 600,SD 602A,SD 615/16/SD 415,SD 617,SD 625,SD 650/52,SD 800,SD 808,SD 810,SD 820,SD 820Am,SD 835,SD 845,MSM8909W, improper input validation in video_fmt_mp4r_process_atom_avc1() causes a potential buffer overflow.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
10/10
10/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Qualcomm -> Sd 600 firmware 
Qualcomm -> Mdm9206 firmware 
Qualcomm -> Sd 602a firmware 
Qualcomm -> Mdm9607 firmware 
Qualcomm -> Sd 615 firmware 
Qualcomm -> Mdm9650 firmware 
Qualcomm -> Sd 616 firmware 
Qualcomm -> Msm8909w firmware 
Qualcomm -> Sd 617 firmware 
Qualcomm -> S820am firmware 
Qualcomm -> Sd 625 firmware 
Qualcomm -> Sd 205 firmware 
Qualcomm -> Sd 650 firmware 
Qualcomm -> Sd 210 firmware 
Qualcomm -> Sd 652 firmware 
Qualcomm -> Sd 212 firmware 
Qualcomm -> Sd 800 firmware 
Qualcomm -> Sd 400 firmware 
Qualcomm -> Sd 808 firmware 
Qualcomm -> Sd 410 firmware 
Qualcomm -> Sd 810 firmware 
Qualcomm -> Sd 412 firmware 
Qualcomm -> Sd 820 firmware 
Qualcomm -> Sd 415 firmware 
Qualcomm -> Sd 835 firmware 
Qualcomm -> Sd 425 firmware 
Qualcomm -> Sd 845 firmware 
Qualcomm -> Sd 430 firmware 
Qualcomm -> Sd 450 firmware 

 References:
http://www.securityfocus.com/bid/103292
https://source.android.com/security/bulletin/2018-03-01

Copyright 2022, cxsecurity.com

 

Back to Top