Vulnerability CVE-2017-17833


Published: 2018-04-23

Description:
OpenSLP releases in the 1.0.2 and 1.1.0 code streams have a heap-related memory corruption issue which may manifest itself as a denial-of-service or a remote code-execution vulnerability.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Redhat -> Enterprise linux desktop 
Redhat -> Enterprise linux server 
Redhat -> Enterprise linux server aus 
Redhat -> Enterprise linux server eus 
Redhat -> Enterprise linux server tus 
Redhat -> Enterprise linux workstation 
Openslp -> Openslp 
Lenovo -> Thinksystem hr650x firmware 
Lenovo -> Thinksystem sr630 firmware 
Lenovo -> Xclarity administrator 
Lenovo -> Thinkserver rd350 firmware 
Lenovo -> Thinkserver rd350g firmware 
Lenovo -> Thinkserver rd350x firmware 
Lenovo -> Thinkserver rd440 firmware 
Lenovo -> Thinkserver rd450 firmware 
Lenovo -> Thinkserver rd450x firmware 
Lenovo -> Thinkserver rd550 firmware 
Lenovo -> Thinkserver rd650 firmware 
Lenovo -> Thinkserver sd350 firmware 
Lenovo -> Thinkserver td350 firmware 
Lenovo -> Thinksystem hr630x firmware 
Debian -> Debian linux 
Canonical -> Ubuntu linux 

 References:
http://support.lenovo.com/us/en/solutions/LEN-18247
https://access.redhat.com/errata/RHSA-2018:2240
https://access.redhat.com/errata/RHSA-2018:2308
https://lists.debian.org/debian-lts-announce/2018/04/msg00029.html
https://sourceforge.net/p/openslp/mercurial/ci/151f07745901cbdba6e00e4889561b4083250da1/
https://usn.ubuntu.com/3708-1/

Copyright 2020, cxsecurity.com

 

Back to Top