Vulnerability CVE-2017-2649


Published: 2018-07-27

Description:
It was found that the Active Directory Plugin for Jenkins up to and including version 2.2 did not verify certificates of the Active Directory server, thereby enabling Man-in-the-Middle attacks.

Type:

CWE-295

(Certificate Issues)

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Jenkins -> Active directory 

 References:
http://www.securityfocus.com/bid/96986
https://jenkins.io/security/advisory/2017-03-20/

Copyright 2020, cxsecurity.com

 

Back to Top