Vulnerability CVE-2017-2809


Published: 2017-09-14   Modified: 2017-09-15

Description:
An exploitable vulnerability exists in the yaml loading functionality of ansible-vault before 1.0.5. A specially crafted vault can execute arbitrary python commands resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Ansible-vault project -> Ansible-vault 

 References:
http://www.securityfocus.com/bid/100824
https://github.com/tomoh1r/ansible-vault/blob/v1.0.5/CHANGES.txt
https://github.com/tomoh1r/ansible-vault/commit/3f8f659ef443ab870bb19f95d43543470168ae04
https://github.com/tomoh1r/ansible-vault/issues/4
https://www.talosintelligence.com/vulnerability_reports/TALOS-2017-0305

Copyright 2021, cxsecurity.com

 

Back to Top