Vulnerability CVE-2017-6024


Published: 2017-05-05   Modified: 2017-05-06

Description:
A Resource Exhaustion issue was discovered in Rockwell Automation ControlLogix 5580 controllers V28.011, V28.012, and V28.013; ControlLogix 5580 controllers V29.011; CompactLogix 5380 controllers V28.011; and CompactLogix 5380 controllers V29.011. This vulnerability may allow an attacker to cause a denial of service condition by sending a series of specific CIP-based commands to the controller.

Type:

CWE-400

(Uncontrolled Resource Consumption ('Resource Exhaustion'))

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.1/10
6.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Complete
Affected software
Rockwellautomation -> Controllogix 5580 firmware 
Rockwellautomation -> Compactlogix 5830 firmware 

 References:
http://www.securityfocus.com/bid/98309
https://ics-cert.us-cert.gov/advisories/ICSA-17-094-05

Copyright 2020, cxsecurity.com

 

Back to Top