Vulnerability CVE-2017-6410


Published: 2017-03-02

Description:
kpac/script.cpp in KDE kio before 5.32 and kdelibs before 4.14.30 calls the PAC FindProxyForURL function with a full https URL (potentially including Basic Authentication credentials, a query string, or PATH_INFO), which allows remote attackers to obtain sensitive information via a crafted PAC file.

Type:

CWE-319

(Cleartext Transmission of Sensitive Information)

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
KDE -> Kdelibs 
KDE -> KIO 

 References:
http://www.debian.org/security/2017/dsa-3849
http://www.securityfocus.com/bid/96515
https://www.kde.org/info/security/advisory-20170228-1.txt

Copyright 2020, cxsecurity.com

 

Back to Top