Vulnerability CVE-2018-0735


Published: 2018-10-29

Description:
The OpenSSL ECDSA signature algorithm has been shown to be vulnerable to a timing side channel attack. An attacker could use variations in the signing algorithm to recover the private key. Fixed in OpenSSL 1.1.0j (Affected 1.1.0-1.1.0i). Fixed in OpenSSL 1.1.1a (Affected 1.1.1).

Type:

CWE-320

(Key Management Errors)

Vendor: Debian
Product: Debian linux 
Version: 9.0; 8.0;
Vendor: Oracle
Product: Peoplesoft enterprise peopletools 
Version:
8.57
8.56
8.55
See more versions on NVD
Product: Primavera p6 enterprise project portfolio management 
Version: 8.4; 18.8;
Product: Mysql 
Version:
8.0.4
8.0.3
8.0.2
8.0.13
8.0.12
8.0.11
8.0.1
8.0.0
5.7.9
5.7.8
5.7.7
5.7.6
5.7.5
5.7.4
5.7.3
5.7.24
5.7.23
5.7.22
5.7.21
5.7.20
5.7.2
5.7.19
5.7.18
5.7.17
5.7.16
5.7.15
5.7.14
5.7.13
5.7.12
5.7.11
5.7.10
5.7.1
5.7.0
5.6.42
See more versions on NVD
Product: Secure global desktop 
Version: 5.4;
Product: Vm virtualbox 
Version:
5.2.8
5.2.6
5.2.4
5.2.28
5.2.26
5.2.22
5.2.20
5.2.2
5.2.18
5.2.16
5.2.14
5.2.12
5.2.10
5.2.0
5.1.8
5.1.6
5.1.4
5.1.38
5.1.36
5.1.34
5.1.32
5.1.30
5.1.28
5.1.26
5.1.24
5.1.22
5.1.20
5.1.2
5.1.18
5.1.16
5.1.14
5.1.12
5.1.10
5.1.0
5.0.8
5.0.6
5.0.40
5.0.4
5.0.38
5.0.36
5.0.34
5.0.32
5.0.30
5.0.28
5.0.26
5.0.24
5.0.22
5.0.20
5.0.2
5.0.18
5.0.16
5.0.14
5.0.13
5.0.12
5.0.10
5.0.0
See more versions on NVD
Vendor: Canonical
Product: Ubuntu linux 
Version: 18.10; 18.04;

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None

 References:
http://www.securityfocus.com/bid/105750
http://www.securitytracker.com/id/1041986
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=56fb454d281a023b3f950d969693553d3f3ceea1
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=b1d6d55ece1c26fa2829e2b819b038d7b6d692b4
https://lists.debian.org/debian-lts-announce/2018/11/msg00024.html
https://nodejs.org/en/blog/vulnerability/november-2018-security-releases/
https://security.netapp.com/advisory/ntap-20181105-0002/
https://usn.ubuntu.com/3840-1/
https://www.debian.org/security/2018/dsa-4348
https://www.openssl.org/news/secadv/20181029.txt
https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html

Related CVE
CVE-2019-11596
In memcached before 1.5.14, a NULL pointer dereference was found in the "lru mode" and "lru temp_ttl" commands. This causes a denial of service when parsing crafted lru command messages in process_lru_command in memcached.c.
CVE-2019-9928
GStreamer before 1.16.0 has a heap-based buffer overflow in the RTSP connection parser via a crafted response from a server, potentially allowing remote code execution.
CVE-2019-11498
WavpackSetConfiguration64 in pack_utils.c in libwavpack.a in WavPack through 5.1.0 has a "Conditional jump or move depends on uninitialised value" condition, which might allow attackers to cause a denial of service (application crash) via a DFF file ...
CVE-2019-2683
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Options). Supported versions that are affected are 5.6.43 and prior, 5.7.25 and prior and 8.0.15 and prior. Easily exploitable vulnerability allows high privileged att...
CVE-2019-2632
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server : Pluggable Auth). Supported versions that are affected are 5.7.25 and prior and 8.0.15 and prior. Easily exploitable vulnerability allows unauthenticated attacker with...
CVE-2019-2628
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: InnoDB). Supported versions that are affected are 5.7.25 and prior and 8.0.15 and prior. Easily exploitable vulnerability allows high privileged attacker with network access v...
CVE-2019-2627
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Security: Privileges). Supported versions that are affected are 5.6.43 and prior, 5.7.25 and prior and 8.0.15 and prior. Easily exploitable vulnerability allows high p...
CVE-2019-2614
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Replication). Supported versions that are affected are 5.6.43 and prior, 5.7.25 and prior and 8.0.15 and prior. Difficult to exploit vulnerability allows high privileg...

Copyright 2019, cxsecurity.com

 

Back to Top