Vulnerability CVE-2018-1000835


Published: 2018-12-20

Description:
KeePassDX version <= 2.5.0.0beta17 contains a XML External Entity (XXE) vulnerability in kdbx file parser that can result in Disclosure of confidential data, denial of service, SSRF, port scanning.

Type:

CWE-611

(Information Exposure Through XML External Entity Reference)

Vendor: Keepassdx
Product: Keepassdx 
Version: 2.5.0.0;
Product: Keepass dx 
Version: 2.5.0.0;

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial

 References:
https://0dd.zone/2018/10/28/KeePassDX-XXE/
https://github.com/Kunzisoft/KeePassDX/issues/200

Copyright 2019, cxsecurity.com

 

Back to Top